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Assignment 1 – Questions in Excel.

Answer:

1. What is a spreadsheet program? How does it differ from a word processing program?

A spreadsheet program is a program designed to perform calculations in a simple way so that the user can understand.  A spreadsheet consists cells organized into rows and columns, in which formulas can be entered to calculate mathematical operations.  It differs from word processing program in its layout, and its way of functioning.  As stated before, a spreadsheet program is presented to users in rows and columns of cells, while users operate on a word processing program on a blank, plain white space.  A spreadsheet program can be used to perform calculations but a word processing program cannot.
2. What is the difference between a worksheet and a workbook? 

A worksheet, also known as a spreadsheet, is used to store and work with data.  Many, many worksheets are assembled into workbooks, which is the file used to store numerous information in it.

3.   How do you copy and move cell contents? 

a) Double-click the cell that contains the data we want to move or copy. 

b) In the cell, select the characters to move or copy. 

c) To move or copy the selection, click Cut or click copy on the Standard toolbar. 

d) In the cell, click where we want to paste the characters or double-click another cell to move or copy the data. 

e) Click Paste. 

f) Press ENTER. 

4.
How do you use the fill handle to copy contents of cells and to create a    sequence? What type of sequences can be created using the fill handle? 


Using fill handle to copy contents of cells:

a)
Select the cells you want to copy.

b)
Drag the fill handle (black block plus sign) across the cells we want to fill, and then release the mouse button. 


Using fill handle to create a sequence (simple linear trend/exponential growth):

a)
Select at least two cells that contain the starting values for the trend. 

If we want to increase the accuracy of the trend series, select more starting points.
b) Drag the fill handle in the direction you want to fill with increasing or decreasing values. 

For example, if the selected starting values in cells A2:C2 are 2, 4, and 7, drag the fill handle to the right to fill with increasing trend values, or drag it to the left to fill with decreasing values. 
5.
How do you create custom headers and footers? 


We can add custom headers and footers to our documents.  To do this:
a) Click the worksheet that is to be inserted the header and footer.

b) Choose Header and Footer from the View menu.

c) Choose the header or footer in the Header or Footer box.

d) Click Custom Header or Custom Footer.

e) Click in the Left section, Center section, or Right section box, and then click the buttons to insert the header or footer information you want in that section. 

f) Do one or more of the following: 

· To enter additional text for the header or footer, enter the text in the Left section, Center section, or Right section box.

· To start a new line in one of the section boxes, press ENTER.

· To delete a section of a header or footer, select the section that is to be deleted in the section box, and then press BACKSPACE
6. What is a relative cell address reference? How do you change a relative reference to an absolute reference? What is a mixed cell address reference?

a)
Relative cell address reference is the reference of certain cell (or cells) using the relative position of the cell that contains the formula and the cell the reference refers to.  If the position of the cell that contains the formula changes, the reference is changed. If you copy the formula across rows or down columns, the reference automatically adjusts.  For example, we use ‘A3’ as the notation for a relative reference.
b)
If we want to change this relative reference to absolute reference, we use the notation of ‘$A$3’.  If the position of the cell that contains the formula changes, the absolute reference remains the same. If you copy the formula across rows or down columns, the absolute reference does not adjust.

c)
A mixed cell address reference is a reference that uses either an absolute column and relative row, or absolute row and relative column.  For example, we denote it as ‘A$1’.  If you copy the formula across rows or down columns, the relative reference automatically adjusts, and the absolute reference does not adjust.
7.
What is the formula bar? What is the name box?


Formula bar is a bar at the top of the Excel window that is used to enter or edit values or formulas in cells or charts. It displays the constant value or formula stored in the active cell.

Name box is a box at the extreme left of the formula bar that shows the selected cell, chart item, or drawing object.

8.
What is the difference between erasing the contents of a column and deleting the column?

When erasing, we are removing the contents of the cell, leaving the cell blank.  But when deleting, we are removing the whole column, and Excel will move the surrounding cells to fill the space left behind.
9. How will you freeze a part of the worksheet?

Freezing panes allows us to select data that remains visible when scrolling in a sheet. For example, keeping row and column labels visible as you scroll.

To freeze a part of a worksheet, we do one of the following:

a) To freeze panes horizontally: Select the row below where we want the split to appear.

b) To freeze panes vertically: Select the column to the right of where we want the split to appear.

c) To freeze panes both horizontally and vertically: Click the cell below and to the right of where you want the split to appear.

d) Then, on the Window menu, click Freeze Panes.
10. What is the maximum number of significant digits possible in MS Excel?
The maximum number of significant digits possible in MS Excel is 15 digits.

11. What is the difference between a bar chart and a histogram?

A bar chart is a chart where the data is presented either horizontally or vertically in bars.  The bars can be drawn with space between them.

A histogram is a just like a bar chart, except that the data is presented pictorially without space between them.

12.
How will you put the error bars in the x-y plot? Make a table with data points along with their error values, and draw a graph with errors bars shown.  (Hint: See Help facility in Excel)
 a)
Click the data series to which we want to add error bars. 

b) Select Selected Data Series from the Format menu.
c) On the X Error Bars tab or the Y Error Bars tab, select the options we want.
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13.
How will you protect a workbook in MS Excel?

a)
On the Tools menu, point to Protection, and then click Protect Workbook.

b) We can do one or more of the following:

-
To protect the structure of a workbook so that worksheets in the workbook can't be moved, deleted, hidden, unhidden, or renamed, and new worksheets can't be inserted, select the Structure check box.

-
To protect windows so that they are the same size and position each time the workbook is opened, select the Windows check box.

-
To prevent others from removing workbook protection, type a password, click OK, and then retype the password to confirm it.

14.
How to protect only selected cells in MS Excel?
a) Switch to the worksheet you want to protect.

b) Unlock any cells you want users to be able to change: select each cell or range, click Cells on the Format menu, click the Protection tab, and then clear the Locked check box.

c) Hide any formulas that you don't want to be visible: select the cells with the formulas, click Cells on the Format menu, click the Protection tab, and then select the Hidden check box.

d) Unlock any graphic objects you want users to be able to change.  You don't need to unlock buttons or controls for users to be able to click and use them. You can unlock embedded charts, text boxes, and other objects created with the drawing tools that you want users to be able to modify. To see which elements on a worksheet are graphic objects, click Go To on the Edit menu, click Special, and then click Objects.

e) Hold down CTRL and click each object that you want to unlock. 

f) On the Format menu, click the command for the object you selected: AutoShape, Object, Text Box, Picture, Control, or WordArt. 

g) Click the Protection tab. 

h) Clear the Locked check box, and if present, clear the Lock text check box. 

i) On the Tools menu, point to Protection, and then click Protect Sheet.

j) Type a password for the sheet (optional).

k) In the Allow all users of this worksheet to list, select the elements that you want users to be able to change.

l) Click OK, and if prompted retype the password.

15. Explain the different forms of log functions available in MS Excel.
Log, the short for logarithm, is an exponent to which the base must be raised to produce a given number.  
For example; 23 = 8
3 is the exponent to which 2 must be raised to produce 8.

3 is called the logarithm of 8 with base 2.

3 = log 2 8 (base 2 is written here as a subscript)

In MS Excel, there are 2 different functions of logarithm: common logarithm (logarithm with base 10) and natural logarithm (written as ‘ln’).
Common logarithm, or decadic logarithm (here ‘deca’ means ‘ten’), is a logarithm that uses the base 10.  If a certain logarithm is written without a base, it is assumed to be common logarithm.  It is denoted as ‘log 10 x’.  It is also known as Briggsian logarithm, after Henry Briggs, a 17th century mathematician.
Natural logarithm, which was invented by John Napier, is very much different from common logarithm.  It is the logarithm to the base e and is denoted as ‘ln x’ or ‘log e  x’, where e=2.718281828...  The natural logarithm is defined for all positive real numbers x and can also be defined for non-zero complex numbers.
16.  In MS Excel, the argument of the sin functions should be in radians.  Assume that you are provided with a set of angles in degrees.  Use radians function in MS Excel to express the angles in radians and then find out the sin of these functions.
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17. Use of Help facilities in Excel:  Go through the Help facilities in Excel and study several different types of functions.  Explain the application of three different uncommon functions using your own examples. 
AVERAGE: this function is used to find the average (arithmetic mean) of numbers.  For example, the average for the numbers 10, 20 and 30 is 20.

Average = (10 + 20 + 30) / 3



  = 20

MEDIAN: this function is used to find the number in the middle set of the given numbers. For example, the median for the numbers 4 and 6 is 5.

Median = (4 + 6) / 2


= 5

ACOS
: this function is used to return the arccosine of a number, in radians in the range 0 to Pi. The arccosine is the angle whose cosine is number.

  e.g.:  0.05236 (ACOS) = 1.52

18. Calculation using Formulas: Select any formula (as complicated as possible) from any one of your textbooks. Use Excel to calculate this formula, by entering the constants and the variables separately.  (For example:
i. Gas constant = … units

ii. Temperature =… units

iii. Pressure        =…  units

iv. Volume        =  … formula)
Boyle’s Law:

P1V1 = P2V2; where P1 = initial pressure, P2 = final pressure, V1 = initial volume and V2 = final volume.


We assume that P1 = unknown, P2 = 100 kP, V1 = 50m3, V2 = 100m3.  Search for P1.

P1 x 50 = 100 x 100


P1
 = 10000/50



 = 200 kP
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19.
Multiplot: Write down any one formula with two constants (a and b) and one variable (x). (eg. y=a sin(bx) or y=a x + b log (x) …etc).  You can also make up your own formula.  Use Excel to calculate your chosen formula for a range of x values at five different sets of constant values and tabulate them as x vs y with x in the first column and y in the next four columns as follows:
y = a sin (bx)
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Plot all the four curves in the same plot and label them differently.  Comment on the effect of the constants on these plots.

20.
Solving Simultaneous Equations: Write a set of five equations with five variables (eq. p, q, r, s, t and u) and solve them using Excel.  Verify your answer by back substitution.
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21.
Solver exercise: The following data set is obtained in an experiment:
	R
	V

	0.5
	127.0355

	1.0
	48.0715

	1.5
	12.1348

	2.0
	8.3139

	2.1
	5.3366

	2.2
	3.1064

	2.3
	1.5361

	2.4
	0.5472

	2.5
	0.0689

	2.6
	0.0374

	2.7
	0.3957

	2.8
	1.0921

	2.9
	2.0807

	3.0
	3.3199

	3.1
	4.7728

	3.2
	10.0998

	3.5
	20.7786

	4.0
	31.9924

	4.5
	42.6319

	5.0
	52.1824

	5.5
	60.4667

	6.0
	67.4911


Use the solver module in Excel to fit the data using the equation 

V=a(1-exp(-b(R-c)))2,

where a, b and c are constants to be determined.  Use solver to determine these constants.  Calculate the V values using the values of a, b and c that you had found out by excel.  Plot the experimental and the calculated data in the same plot and label them properly.  What is the value of V at R=1.25 and R=c?
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22. Grades distribution: Consider a class consisting of 12 to 20 students.  Create      their mark list in their final exam.   The list should contain their names and their marks in two columns. Use the nested “if condition” to determine their grades (eg. A, B ….) and list them in the third column.  Present their grade distribution as a histogram and as a pie chart.
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23.
Computerization of the laboratory report:  Present any of your experimental laboratory report involving detailed calculations and graphs, as an Excel workbook.  Your report should be self-contained and contain all the details to verify your graphs and results.  In short it should look as lab report that you would submit after completing your experiment.
24.
Exercises done in the computer lab: Present a complete report of all the excel exercises done during the lab hours.
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